LON-UK | Carrier Transport Issues

Incident Report for Atlantic.Net

Update

Good morning,

We are continuing to work closely with our upstream provider to implement the necessary changes and restore services as quickly as possible.

Further updates will be posted at: https://status.atlantic.net

We sincerely appreciate your continued patience and understanding as we work to fully resolve the issue.

Atlantic.Net Support
Toll-Free: 1-888-618-DATA (3282)
International: +1-321-206-3734
Posted Jul 14, 2025 - 12:09 EDT

Identified

Good morning,

We are currently experiencing a major service disruption in the London region due to an outage affecting one of our upstream carriers. Our team has identified the issue and is actively working with the carrier to implement a resolution.

We will continue to post updates as they become available at: https://status.atlantic.net

We appreciate your patience and understanding as we work to restore full service.

Atlantic.Net Support
Toll-Free: 1-888-618-DATA (3282)
International: +1-321-206-3734
Posted Jul 14, 2025 - 10:57 EDT
This incident affects: Services (Cloud Services - Server Provisioning, DNS, Cloud Services - Servers) and Regions (London, United Kingdom (EU-West-1)).