Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2025 - 08:00 EST
Scheduled
As an operational activity, we will be conducting a HVB shutdown for DNO maintenance. This activity will be conducted by JLL engineers and they will be accompanied by the VIRTUS on-site team.
What does this mean to you
There should be no impact to your service. The critical load of the HVB head end will be transferred to HV generators. We will shut down the HVB supply to allow the DNO to safely work on their equipment. We will ensure you are kept updated upon the start and completion of the works.
Posted Jan 20, 2025 - 23:18 EST
This scheduled maintenance affected: Regions (London, United Kingdom (EU-West-1)).