ORL-FL | Legacy Email Certificate Error
Incident Report for Atlantic.Net
Resolved
After review, it has been determined that the security issues appear to be related to Outlook and iOS devices not recognizing a newly updates SSL certificate. Where possible, this alert can be ignored. If the application cannot override the alert, the account should be backed up, removed, and re-added to the app. Alternately, the https://webmail.atlantic.net web portal can be used instead of third party applications.
Posted Feb 22, 2023 - 12:03 EST
Update
We are continuing to investigate this issue.
Posted Feb 22, 2023 - 10:14 EST
Investigating
Several customers have reported certificate errors with legacy email services. The server is still functioning, however, some devices are displaying security alerts when trying to access the server.

Currently, engineers are investigating the matter.
Posted Feb 22, 2023 - 10:14 EST
This incident affected: Services (Email Hosting, Shared Web Hosting).