Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2024 - 09:15 EDT
Scheduled
The Network Operations team is performing maintenance on one of the Orlando data center's edge routers. Maintenance work will be brief and will not impact service or performance. Please contact support@atlantic.net if you have any questions.
Posted Sep 11, 2024 - 09:09 EDT
This scheduled maintenance affected: Regions (Orlando, Florida (USA-East-1)).