Network connectivity issues in the NYC (New York) region have been mitigated. All services are currently accessible, and we will continue to monitor for stability.
We will continue to post further updates as necessary.
Posted Nov 21, 2025 - 03:24 EST
Identified
We are aware of potential carrier transport issues in the region that is causing higher-than-normal levels of packet loss for services. We are currently working with our upstream carrier to resolve the issue. You may experience periods where your Cloud Servers are intermittently accessible while our team works to resolve the issue.
Posted Nov 21, 2025 - 02:17 EST
This incident affected: Regions (New York, New York (USA-East-2)) and Services (Cloud Services - Server Provisioning, Cloud Services - Servers).