We have found that the root cause of the connectivity issues reported previously was a carrier connection failure at our Orlando site. Connectivity in the Orlando (ORL) region has returned to normal. All services are currently accessible, and we will continue to monitor for stability.
We will continue to post further updates as necessary.
Posted Nov 11, 2025 - 02:34 EST
Monitoring
We have found that the root cause of the connectivity issues reported previously was a carrier connection failure at our Orlando site. Connectivity in the Orlando (ORL) region has returned to normal. All services are currently accessible, and we will continue to monitor for stability.
We will continue to post further updates as necessary.
Posted Nov 11, 2025 - 02:19 EST
Identified
We are aware of potential carrier transport issues in these regions and are currently working with our upstream carrier to resolve the issue. You may experience periods where your Cloud Servers are inaccessible while our team works to resolve the issue.
We will post further updates as we have more information available.
Posted Nov 11, 2025 - 01:37 EST
This incident affected: Regions (Orlando, Florida (USA-East-1)) and Services (Cloud Services - User Portal, Cloud Services - Server Provisioning, Cloud Services - Web API, Cloud Services - Servers).