Connectivity in the Orlando region has returned to normal. All services are currently accessible, and we will continue to monitor for stability.
We will continue to post further updates as necessary.
Posted Jan 09, 2026 - 10:47 EST
Identified
We have identified the root cause of the issue as a result of instability from one of our upstream carriers. We are currently working closely with them to resolve the issue. You may experience periods where your services are inaccessible while our team works to resolve the issue.
We will post further updates as we have more information available.
Posted Jan 09, 2026 - 10:08 EST
Update
Our phone systems may be unreachable at this time. If you require assistance, please send an email to support@atlantic.net.
Posted Jan 09, 2026 - 09:36 EST
Investigating
We are currently investigating an issue that is affecting services in the Orlando region. We will continue to provide updates as we learn more about the issue.
Posted Jan 09, 2026 - 09:34 EST
This incident affected: Regions (Orlando, Florida (USA-East-1)).