DAL2 | Network-Level Outage

Incident Report for Atlantic.Net

Postmortem

Location: DAL2 (Dallas Data Center)
Date: April 30, 2026

Summary

On April 30, 2026, Atlantic.Net experienced a service disruption within the DAL2 network infrastructure due to a Distributed Denial of Service (DDoS) attack. The attack resulted in intermittent connectivity and service degradation for affected customers.

The incident was promptly detected by monitoring systems and escalated to the Network Engineering team, who initiated mitigation procedures. Full service restoration was achieved within 28 minutes of the initial impact.

Incident Timeline

Total Outage Duration: 28 Minutes
Customer Impact (SLA): 28 Minutes

Impact

  • Customers hosted within the DAL2 environment experienced:

    • Network latency
    • Packet loss
    • Intermittent or complete loss of connectivity
  • The impact duration varied but did not exceed the total outage window of 28 minutes.

Root Cause

The outage was caused by a Distributed Denial of Service (DDoS) attack targeting Atlantic.Net’s DAL2 network infrastructure.

The volume and nature of malicious traffic temporarily overwhelmed network resources, resulting in degraded performance and partial service disruption.

Detection

The event was identified through:

  • Automated alerts from Network Monitoring Services (NMS)
  • Customer-reported issues via support tickets and inbound calls

Mitigation and Resolution

Upon escalation, the Network Engineering team performed the following actions:

  • Analyzed inbound traffic patterns to identify malicious sources
  • Implemented traffic filtering and mitigation controls
  • Applied rate limiting and/or upstream filtering where applicable
  • Stabilized affected network segments

These actions successfully mitigated the attack and restored normal network operations by 15:40 EST.

Conclusion

This incident was the result of an external malicious DDoS attack. Atlantic.Net’s monitoring and response procedures enabled rapid identification and mitigation, limiting customer impact to 28 minutes.

We remain committed to improving network resilience and minimizing the impact of similar events in the future.

Posted May 07, 2026 - 01:17 EDT

Resolved

This incident has been resolved.
Posted May 01, 2026 - 02:45 EDT

Monitoring

We are aware of a network-level issue that caused connectivity issues for some customers in the Dallas data center. We have identified and resolved the issue and are continuing to monitor the situation. We will provide more information to affected customers as we gather more details.
Posted Apr 30, 2026 - 15:47 EDT
This incident affected: Regions (Dallas, Texas (USA-Central-1)).