Ubersmith Helpdesk System Upgrade - Maintenance Extension

Incident Report for Atlantic.Net

Resolved

The Ubersmith helpdesk optimization functions have completed and normal functionality is restored.
Posted Nov 07, 2025 - 09:48 EST

Identified

The Ubersmith Helpdesk maintenance has been extended in order to accommodate additional optimization functions. The portal at https://helpdesk.atlantic.net is currently available, but there may be a delay in responding to customer email requests as this work is completed.

How to contact Support during the upgrade:
Phone: 888-618-3282
Email: support@atlantic.net

We will post an update when the maintenance begins and another when service is restored.
Posted Nov 07, 2025 - 05:55 EST
This incident affected: Regions (Orlando, Florida (USA-East-1), New York, New York (USA-East-2), Ashburn, Virginia (USA-East-3), Dallas, Texas (USA-Central-1), San Francisco, California (USA-West-1), Toronto, Ontario (Canada-East-1), London, United Kingdom (EU-West-1), Singapore, SG (AP-Southeast--1)) and Services (Cloud Services - User Signups, Support Portal).