ORL-FL | Partial Phone Support Service Failure

Incident Report for Atlantic.Net

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 14:07 EDT

Identified

We are currently experiencing technical difficulties with our phone lines. Currently, the primary phone number for our Support staff, 1 (888) 618-3282, cannot be reached. We are working closely with our upstream carrier to resolve this issue. We apologize for any inconvenience this may have caused, and we are working to resolve the issue as quickly as possible.

Support may still be reached via the following phone numbers as normal:

US: 1 (866) 618-3282
International: 1 (321) 206-3734

During our investigation, if you experience any difficulties with the additional numbers provided above, we ask that you please email our support team at support@atlantic.net. Our team is available 24/7 to address any concerns you may have, and they will respond to your email as soon as possible. Thank you for your continued patience.
Posted Apr 24, 2025 - 09:33 EDT
This incident affected: Regions (Orlando, Florida (USA-East-1)) and Services (Support Portal).