NYC-NY | Data Center Power Outage

Incident Report for Atlantic.Net

Postmortem

NYC1 Data Center Power Outage — Incident Report

Date: September 17, 2025 (EDT)
Location: NYC1
Severity: Severity 1 (Critical)
Impact: Full site outage affecting access to all services in NYC1
Measured outage duration: 1 hour 28 minutes 36 seconds

Summary

At 09:34:24 EDT on September 17, 2025, our monitoring detected a loss of access to the NYC1 environment. Upstream carrier services feeding the site were unavailable, resulting in a site-wide outage. Service was restored at 11:03:00 EDT. We are awaiting the data center operator’s formal Reason for Outage (RFO). Preliminary provider updates indicate the event was related to a power issue within the facility that affected multiple carriers.

Timeline (EDT)

  • 09:34:24 Detection by network monitoring
  • 09:42:24 Escalation initiated
  • 09:47:24 Incident acknowledged; mitigation started and coordinated bridge established
  • 11:03:00 Service restored

Customer Impact

  • Access to NYC1 services was unavailable during the times above.
  • The SLA outage duration equals the full incident duration.

What We Did

  • Activated our incident response and opened a live coordination bridge.
  • Engaged our carrier partners and the data center operator to confirm scope and restoration activities.
  • Provided periodic customer updates during the event window.
  • Verified recovery and confirmed service availability at resolution.

Current Status and Next Steps

  • We are awaiting the facility operator’s formal RFO. Once received, we will share a summary of the findings and any confirmed contributing factors.
  • We are reviewing out-of-band access resiliency and evaluating additional diversity options for this footprint to reduce exposure to similar facility-level events.
  • We will update customers if any actions are required on your side.

Lessons Noted

  • Early and steady communications are critical during facility-level events; we will continue to follow a consistent update cadence in similar incidents.
  • We are refining our first-hour response checklist to further standardize triage and external messaging.

Questions or Follow-Up

If you have questions about this incident or your specific services, please reply to this notice or contact Support through your usual channel. We will provide a customer summary of the facility RFO once it is available.

Posted Oct 16, 2025 - 03:42 EDT

Resolved

We have confirmed continued stability over the past hour and can now confirm this outage is fully resolved. Our Network Engineering and Management teams are preparing a formal incident report, which will be shared with all affected customers.

If you have any questions regarding this incident or any related concerns, please contact us at support@atlantic.net.

Thank you for your continued patience as we investigated this outage.
Posted Sep 17, 2025 - 12:55 EDT

Monitoring

We have begun to observe service restoration in the region at this time.

Our Network Engineering and Management teams are continuing to work closely with carriers and facility operations to ensure services are fully restored. We will continue to provide updates as more information becomes available.

We appreciate your patience as we work toward resolution.
Posted Sep 17, 2025 - 11:24 EDT

Identified

We have identified the root cause of this issue as a power failure at the facility in Clifton, NJ, affecting all carriers and services. Field operations are currently on-site working to restore power and service.

Our Network Engineering and Management teams are continuing to communicate with carriers and facility operations regarding this incident. We will continue to provide updates as more information becomes available.

We recommend directing all inquiries to support@atlantic.net, as phone lines are currently experiencing high volume.

We appreciate your patience as we work toward resolution.
Posted Sep 17, 2025 - 11:00 EDT

Investigating

We are aware of potential carrier transport issues in this region and are currently working with our upstream carrier to resolve the issue. You may experience periods where your Cloud Servers are inaccessible while our team works to resolve the issue.

We will post further updates as we have more information available.
Posted Sep 17, 2025 - 09:54 EDT
This incident affected: Regions (New York, New York (USA-East-2)) and Services (Cloud Services - Server Provisioning, Cloud Services - Servers).