Experiencing Intermittent 3CX Issues

Incident Report for Atlantic.Net

Resolved

This incident has been resolved. All numbers are operational
Posted Nov 20, 2023 - 21:25 EST

Update

The current displayed number is operational. +13212063734
Posted Nov 20, 2023 - 20:59 EST

Identified

Our DevOps engineers have discovered issues with 888 numbers.
Posted Nov 20, 2023 - 20:24 EST
This incident affected: Regions (Orlando, Florida (USA-East-1)).