The incident has been resolved and functionality of our Cloud DNS has been restored
Posted May 31, 2023 - 13:00 EDT
Monitoring
The issue has been identified and corrected. We are now monitoring the results.
Posted May 31, 2023 - 12:11 EDT
Investigating
Several customers have reported issues with our Cloud DNS, and our engineers are investigating the issue.
Posted May 31, 2023 - 11:54 EDT
This incident affected: Regions (Orlando, Florida (USA-East-1), New York, New York (USA-East-2), Ashburn, Virginia (USA-East-3), Dallas, Texas (USA-Central-1), San Francisco, California (USA-West-1), Toronto, Ontario (Canada-East-1), London, United Kingdom (EU-West-1)) and Services (DNS).