Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 30, 2026 - 20:00 EST
Scheduled
We will be performing scheduled maintenance to migrate and upgrade the platforms that power our cloud control panel and API.
MAINTENANCE WINDOW January 30, 2026 at 8:00 PM – January 31, 2026 at 12:00 AM (ET)
CUSTOMER IMPACT All customer Cloud Services will remain fully operational.
Access to the Cloud Control Panel and API may be temporarily unavailable for periods of time.
Self-service actions such as Cloud Server provisioning, reboots, backup restores, VNC console access, etc. may be temporarily unavailable during the affected period. If assistance is needed while this maintenance is underway, please contact the Support Team.
PURPOSE FOR MAINTENANCE This maintenance is required to improve performance and support long-term continued reliability. We appreciate your patience and will provide updates if anything changes.
SUPPORT CONTACT If you have any questions or concerns, please contact us: Email: support@atlantic.net or via phone at 1-888-618-3282
We appreciate your understanding and cooperation as we perform this essential maintenance.
Posted Jan 28, 2026 - 13:47 EST
This scheduled maintenance affected: Regions (Orlando, Florida (USA-East-1), New York, New York (USA-East-2), Ashburn, Virginia (USA-East-3), Dallas, Texas (USA-Central-1), San Francisco, California (USA-West-1), Toronto, Ontario (Canada-East-1), London, United Kingdom (EU-West-1), Singapore, SG (AP-Southeast--1)) and Services (Cloud Services - User Portal, Cloud Services - Web API).