ORL-FL | Networking issues

Incident Report for Atlantic.Net

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 16:18 EDT

Monitoring

We are still testing and monitoring the situation.
Posted Jun 20, 2025 - 15:32 EDT

Investigating

We have had reports of network slowness and dropped connections at our Orlando facility. We are investigating.
Posted Jun 20, 2025 - 15:00 EDT
This incident affected: Regions (Orlando, Florida (USA-East-1)).