Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 02, 2025 - 01:00 EST
Scheduled
As part of our networking infrastructure updates in Ashburn, we will be adding our second core router back into service tonight as the secondary in the router pair. This maintenance was originally planned for Friday morning but was not completed at that time.
We do not anticipate any service disruptions, but brief routing adjustments may occur as the router is reintroduced.
Posted Mar 01, 2025 - 22:21 EST
This scheduled maintenance affected: Services (Cloud Services - User Signups, Cloud Services - User Portal, Cloud Services - Server Provisioning, Cloud Services - Web API, DNS, Email Hosting, Shared Web Hosting, Support Portal, Cloud Services - Servers) and Regions (Ashburn, Virginia (USA-East-3)).