ORL-FL | Internal Network Issues
Incident Report for Atlantic.Net
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 19:42 EST
Identified
Routine maintenance of a firewall in the Orlando data center has affected some our internal systems, including ticketing. Our Network Operations team is currently working to resolve the issue. Should you have any questions, you can contact us via email or phone number using the information below.

Toll Free: (888)618-3282
International: +1-321-206-3734
Email: support@atlantic.net
Posted Jan 20, 2025 - 12:28 EST
This incident affected: Regions (Orlando, Florida (USA-East-1)) and Services (Email Hosting, Support Portal).