Resolved — Nov 04, 2025 20:30 EST Phone service has been restored. Our provider implemented a fix for the registration issue, and inbound/outbound calls are operating normally. If you encounter any further problems, please email support@atlantic.net .
Posted Nov 04, 2025 - 20:44 EST
Monitoring
Phones have been restored, inbound and outbound calls are functioning; we are monitoring for stability and will post an additional update when we have confirmation that the issue is fully resolved. In
Posted Nov 04, 2025 - 19:32 EST
Update
Work on this issue is still underway, we'll provide further updates as we receive them.
Posted Nov 04, 2025 - 16:55 EST
Identified
Our phone provider has identified the issue and is in the process of implementing a fix, we'll provide an update as we have more details.
Posted Nov 04, 2025 - 15:51 EST
Investigating
Status: Major Outage
Started: Nov 04, 2025 14:08 EST
Last update: Nov 04, 2025 14:55 EST
Impact: Customers may be unable to reach Atlantic.Net Support by phone. Inbound calls may fail to connect; outbound callbacks may be delayed.
Workarounds (please use these): Email: support@atlantic.net (urgent tickets will be prioritized) For emergencies affecting production availability, include “SEV-1” in the email subject.
We’ll post the next update by 15:30 EST or sooner if status changes.
Posted Nov 04, 2025 - 14:59 EST
This incident affected: Regions (Orlando, Florida (USA-East-1), New York, New York (USA-East-2), Ashburn, Virginia (USA-East-3), Dallas, Texas (USA-Central-1), San Francisco, California (USA-West-1), Toronto, Ontario (Canada-East-1), London, United Kingdom (EU-West-1), Singapore, SG (AP-Southeast--1)).