Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 27, 2025 - 20:00 EST
Scheduled
Our Network Engineering team will be performing maintenance on our Production Corporate Firewalls. During this maintenance window there may be intermittent periods that Cloud Portal features may not be available to customers. Features that may not be available include VNC console, hard/soft reboot functions for Cloud Servers, restore of backups, snapshot creation/transfers, and block storage management. Additionally, during this maintenance window, our Support Team's monitoring of customer Cloud Servers, Dedicated Cloud Hosts, and transit paths to our remote datacenters will be limited. If you are experiencing an issue during this maintenance window it is advised to please call our support line for a faster response.
Posted Jan 24, 2025 - 15:07 EST
This scheduled maintenance affected: Regions (Orlando, Florida (USA-East-1), New York, New York (USA-East-2), Ashburn, Virginia (USA-East-3), Dallas, Texas (USA-Central-1), San Francisco, California (USA-West-1), Toronto, Ontario (Canada-East-1), London, United Kingdom (EU-West-1), Singapore, SG (AP-Southeast--1)) and Services (Cloud Services - User Signups, Cloud Services - User Portal, Cloud Services - Server Provisioning, Cloud Services - Web API, Cloud Services - Servers).