ORL-FL | Emergency Maintenance on Mail Platform

Incident Report for Atlantic.Net

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 11:56 EDT

Identified

We will be conducting emergency maintenance on our mail platform to prevent a potential system failure. This maintenance is scheduled to begin at 11:30 AM, approximately 20 minutes from now.

We expect the downtime for email services to be brief, lasting only a few minutes. We appreciate your patience and will update here promptly once services have been restored.

Atlantic.Net Support
Toll-Free: 1-888-618-DATA (3282)
International: +1-321-206-3734
Posted Apr 30, 2025 - 11:11 EDT
This incident affected: Services (Email Hosting).