Support Portal | Ticketing System Delay
Incident Report for Atlantic.Net
Resolved
This incident has been resolved.
Posted Apr 28, 2024 - 22:39 EDT
Monitoring
Our engineering team has fixed the access to the help desk system, and we are monitoring the results.
Posted Apr 28, 2024 - 16:16 EDT
Investigating
Our support team has become aware of an issue preventing review of tickets through our support helpdesk system. Our engineers are investigating the issue.

In the mean time, if you have any concerns that require support assistance, please call 1-888-616-DATA (3282) and a technician can assist you on the phone.
Posted Apr 28, 2024 - 12:39 EDT
This incident affected: Services (Support Portal).